PostgreSQL მონაცემთა ბაზებით სარგებლობს მრავალი დეველოპერი, ხოლო PostgreSQL-თან სამუშაოდ  phpPgAdmin-ითაც  სარგებლობს. phpPgAdmin-ის ახალ 5.1 ვერსიაში აღმოვაჩინე რომ ის არ არის თავსებადი PHP7 ვერსიასთან, რის გამოც ვერ აკეთებს მონაცემთა ბაზის ექსპორტს. საიტზეც არაფერი ეწერა ამ პრობლემის შესახებ და ვერსიაც იგივე 5.1 დამხვდა. ან უნდა გადავსულიყავი php5 ვერსიაზე ან უნდა შემეცვალა კოდი ისე რომ ის თავსებადი ყოფილიყო php7 ვერსიასთან. ასეც მოვიქეცი სადაც არათავსებადი კოდი ვნახე განვაახლე და შესაბამისობაში მოვიყვანე php7 თან. რადგანაც ეს შეიძლება ჩემს გარდა კიდევ არაერთ ადამიანს დასჭირდეს, ჩამოსატვირთი ბმულიც დავდე და შეგიძლიათ ისარგებლოთ. მოცემული პაკეტი არათავსებადია php 4 და უფრო ძველ ვერსიებთან, ხოლო php5 და უფრო ახალ ვერსიაბთან მუშაობს.

ჩამოსატვირთი ბმული >>

Download phpPgAdmin 5.1 compatible with PHP7 >>